Results 1 to 2 of 2

Thread: SuperTrapp Fatshots loose after long ride

  1. #1
    Join Date
    Apr 2015
    Location
    United States
    Posts
    3

    Default SuperTrapp Fatshots loose after long ride

    I installed a set of SuperTrapp Fatshots on my '09 H-D Ultra Classic a few months ago and have really enjoyed them. Two weekends ago, I took a long ride (6.5 hours) up to the North Carolina mountains for a weekend of riding with my brother. When I was wiping the bike down the next morning, I noticed the right side muffler was very loose. In fact, if it weren't for the muffler hanger, it would have fallen off. My brother had a set of tools with him and we were able to tighten the muffler clamp a little bit, but it didn't help. I ended up loosening the clamp, pushing the muffler all the way forward until it bottomed out against the exhaust pipe, then re-tightening the clamp. That seemed to hold it for the weekend, but when I finished the return ride home, the muffler was loose again. The left side muffler is not having this problem. I'm using the standard H-D muffler clamps (part no. 65296-95A), and I had just bought a new set before installing the Fatshots. The clamp is positioned so that it is flush with the end of the muffler neck, fully covering the crimp cutouts on the neck (which, by the way are a little shorter than the width of the clamp). Any suggestions on how to fix this problem. Could it just be a defective clamp? Thanks!

  2. #2
    Join Date
    Feb 2015
    Location
    United States
    Posts
    27

    Default

    I would try swapping the clamps from side to side and see if the issue repeats itself on the other side. If that doesn't resolve the issue try swapping muffler bodies. The swaps should point to the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •