Results 1 to 3 of 3

Thread: Supermegg 2:1 install - did I miss a clamp

  1. #1
    hillcountryflt Guest

    Default Supermegg 2:1 install - did I miss a clamp

    I have been running the Supermeggs 2:1 on my 06 Ultra and have been very happy with them. With my updated fuel map, I lost 2 or 3 mpg but that would be a question for my tuner folks.
    Lately, I have been trying to trace down a rattle that gets worse when the bike is warmed up and in doing so, I noticed that there is no clamp attaching the lower pipe to the bracket by the transmission cover. My exhaust is supported by the flanges at the exhaust ports and the bolts at the muffler mounting bracket.
    Did I miss something?

  2. #2
    Join Date
    Feb 2017
    Location
    Cleveland, Ohio
    Posts
    0

    Default

    Yes there should be a #24 hose clamp that would install around the front head pipe, between the front and rear pipes, at the stock transmission mount point. Wrap the clamp around the stock bracket.

  3. #3
    hillcountryflt Guest

    Default The "heavier duty" clamp provided was too big

    You guys sent me a heavier duty t-clamp but it was too big as it would not cinch up so I ended up using the regular hose clamp.
    After putting about 1k miles on the bike following the re-install, an exhaust bolt broke on the front cylinder and will be pulling the exhaust system again as the bolt broke flush with the head.
    My service guy thinks the exhaust is moving around too much and causing the bolt to break. We had replaced a rear exhaust bolt about two weeks ago.
    Any thoughts as to exhaust causing bolt breakage. We are definitely not overtightening.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •