Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Rattling or buzzing noise

  1. #1
    RKingDon Guest

    Default Rattling or buzzing noise

    I have an 08 RK with SuperMeg 2-1. I was originally running 20 disks with closed but went to 14 disks and the slotted open billet end cap. I had it dynoed and the bike runs great but there seems to be a buzzing or rattling noise from the pipe which is especially noticeable during idle. It did it both before and after I changed end caps. It is some less noticeable now with the open cap but still there all the same. All the screws are tight.

    Is it possible the core/baffles/packing is loose inside the pipe? I find this noise very annoying and takes away from what would otherwise be a great sound out of this pipe. I can't believe this is normal. The pipes are new since March. Any idea?

  2. #2
    bschultz Guest

    Default

    I know you mentioned the screws were tight; however does this include the two button heads on the bottom (exit end) of the megaphone?
    Is the sound ALL the time or at specific times like "under load", "no load", "idle", "cruise"?

  3. #3
    RKingDon Guest

    Default

    I checked those too, they are tight. The noise is at light load "cruise" and idle but really noticable at idle. I don't here it under heavy load but of course it's barking pretty loud at that point.

  4. #4
    bschultz Guest

    Default

    Try putting some pressure on the end cap (pushing towards the front of the muffler) with a piece of wood or something that won't damage or scratch anything but still act as an isulator against getting burnt. You should be able to do this during idle. If the sound goes away it could be the core may not seating in the inlet of the muffler body properly (not very common though).
    In either case contact our Customer Service Department to process a warranty claim. Have system part number, "proof of purchase"(for faxing or emailing), personal info (including shipping address & phone #) availalable.

  5. #5
    RKingDon Guest

    Default

    Ok, I'll give that a try tonight. If that is the problem, can it simply be removed and reinserted to solve the problem?

  6. #6
    bschultz Guest

    Default

    You can try that; however if it doesn't work contact us.

  7. #7
    RKingDon Guest

    Default

    I won't void the warranty if I do that will I?

  8. #8
    bschultz Guest

    Default

    No, you have already made us aware of the issue.

  9. #9
    RKingDon Guest

    Default

    I finally had a chance to try your suggestion to no avail. If it made a difference it was not noticable. I then took off the EC and screws out of the bottom of the muffler to see if the core/packing would move but it didn't.

    Suggestions? Is the core removable on this muffler? It didn't appear to want to come out but I was also reluctant to try to hard if you know what I mean.

  10. #10
    bschultz Guest

    Default

    The core assembly on a 2:1 SuperMeg IS repackable and therefore comes out. The easiest way to remove the core is with the muffler body off the bike. Work at knocking the core out the rear of the pipe from the inlet end with a wooden dowel (section of broom handle).
    If you call us we will assign an RMA# and you can send it in for repair/replacement.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •