PDA

View Full Version : Need HELP with Mean Mothers intall.



DynaGuy
12-20-2009, 10:24 AM
Hi everyone. I just purchased a set of Mean Mothers drag pipes (model # 138-72590) for my bike. They're great looking pipes but I have to say that I'm not happy with the install instructions and especially the bracket that came with the pipe. Unless I did somethng wrong, the bracket is poorly designed.

My bike is a 2008 FXDL (lowrider) with mid controls.

Here's my problem with the bracket. There were two 3/4" spacers that came with the bracket. When installed - per the instructions - the front pipe doesn't align with the back pipe. It seems the bottom 3/4" spacer pushes the bracket out too far which of course pushes the end of the front pipe out. So the result is a crooked front pipe....and it looks awful.

I tried installing it without the bottom spacer but then I can't use the C-clamp and the stock mount (under the timing cover) because the holes dont line up.

My other problem is the back pipe doesn't run even with the swing arm. It seems to sag a little.

Does anyone have a solution to this problem? I spent a lot of money on these pipes and am disappointed that a simple thing like a bracket took all the fun out of this experience for me.

Please help!

Thanks.

bschultz
12-21-2009, 08:25 AM
Check the spacers to see if they are actually 3/4".
The pipes are designed to lined up with the frame not the swing arm.

Our Customer Service Department can assist you during normal working hours of 8am-5pm, Mon-Fri.